Back to overview
Degraded
Applying security and stability fixes on Elasticache
Jul 08 at 04:37am HDT
Affected services
API
Resolved
Jul 08 at 04:53am HDT
Successfully patched important security and stability fixes
Affected services
API
Created
Jul 08 at 04:37am HDT
API should be working albeit slowly
Affected services
API